KodiTips Forums

Video will not play

element12137

  • 2
  • +0/-0
    • View Profile
Video will not play
« on: July 10, 2017, 11:04:32 pm »
I have up to date Kodi and Exodus on both amazon fire stick and windows 10 laptop. Everything runs perfectly well on firestick, but having just downloaded for the laptop I tried to watch some shows, specifically naruto shippuden, not appropriate for child viewing; I can find everything without issue, I get 10+ streams for the episode I wish to view. I get the 'working' symbol, the small play icon appears in the top corner next to the clock.... and then nothing. No error message, no crash or freeze, it simply does not play. The problem persist with other episodes of the same anime, as well as other anime, however movies with a greater number of streams DO play, albeit not as smoothly as on the Fire and says 'slow read rate' ;Any idea what is going on or how to fix?
« Last Edit: July 10, 2017, 11:20:34 pm by element12137 »

D@Cod3r

  • 80
  • +8/-0
    • View Profile
Re: Video will not play
« Reply #1 on: July 12, 2017, 10:25:02 am »
What are you using for your network connection? Wired or Wifi? If Wifi, try a wired connection to see if this solves the problem.

Buzz Marshall

  • 186
  • +16/-2
    • View Profile
Re: Video will not play
« Reply #2 on: July 12, 2017, 05:18:27 pm »
Id start as D@Cod3R already suggested but if the problem persists i'd be looking to kodi's logs for hints...

If i understand what your saying correctly your having the issue just on windows? If so it may be with something support wise that windows isn't properly providing Kodi when trying to play certain streams encoded in a manner it doesn't like... Id start by looking into Kodi's logs for hints... you may need to turn on advanced logging in Kodi to see the pertinent messages... another thing it could be relates to windows network support and how it  handles certain things...Android basically was designed with networking at its core and is pretty simple as far as a operating system goes whereas windows even tho its a network capable os its much more complicated in its implementation of network protocols and stacks... again tho looking thru some logs should at least point you in the right direction... i'd  look at windows logs as well... sounds tho like windows doesnt like the manner those streams are encoded in...

TonyH

  • 425
  • +28/-3
    • View Profile
Re: Video will not play
« Reply #3 on: July 12, 2017, 05:33:14 pm »
Something to try...
I had a lot of problems with my windows 10 PC, just running kodi and installing addons. Turns out it was my crappy anti virus software, namely mcafee running a constant scan on programs and files on the PC. Just for curiosity, try disabling all your scans and firewall and see if there is a difference.
Otherwise, the above advice is excellent!

element12137

  • 2
  • +0/-0
    • View Profile
Re: Video will not play
« Reply #4 on: July 14, 2017, 11:24:05 pm »
I have tried checking Kodi logs and antivirus logs, kodi does not appear to have ANY logs except for 'kodi started' unless I'm looking in the wrong place, and my antivirus shows Kodi as an allowed program in the firewall. Is there a repository with a decoder app that can allow the encryption through? I can't help but feel I might not have had this issue before Fusion shut down

Buzz Marshall

  • 186
  • +16/-2
    • View Profile
Re: Video will not play
« Reply #5 on: July 14, 2017, 11:48:07 pm »
to get more in kodi's logs you may have to turn on debug or increase the logging level inside kodi if your not seeing anything...

as tony suggested tho i'd shut off your anti-virus crap which might mean a reboot to get the running core disabled...

personally i never use any of the commercial crap for anti-virus as it will never catch anything the ingrained Microsoft cant already do... defender in this case is a good as any commercial av if kept updated as pretty much all av software is using opensource collection db's on whats out there on the network... something new is another story and unless some detects it and creates the scan no av is gonna catch it... anyways that whole nother topic... but as a technician i know some av software is more intercepting then others... so rather then just shutting it off while in session actually disable it and reboot and see if that helps... same thing for windows firewall... totally disable it and see... could be a rule in the firewall based on certain types not just where its coming from...

Sara5dawn

  • 89
  • +0/-1
    • View Profile
Re: Video will not play
« Reply #6 on: July 15, 2017, 01:28:45 pm »
I have up to date Kodi and Exodus on both amazon fire stick and windows 10 laptop. Everything runs perfectly well on firestick, but having just downloaded for the laptop I tried to watch some shows, specifically naruto shippuden, not appropriate for child viewing; I can find everything without issue, I get 10+ streams for the episode I wish to view. I get the 'working' symbol, the small play icon appears in the top corner next to the clock.... and then nothing. No error message, no crash or freeze, it simply does not play. The problem persist with other episodes of the same anime, as well as other anime, however movies with a greater number of streams DO play, albeit not as smoothly as on the Fire and says 'slow read rate' ;Any idea what is going on or how to fix?

Did you by any chance install the new windows 10 creator update? I'm asking because I had problems with everything including Kodi after that update!

I went into my computer settings and > updates and security> recovery> restore windows 10 to previous version
it's gonna ask why choose option> then ok

I did mine just yesterday because the update is not stable and really messed up my Laptop.
after going back to previous version everything works just find as it did before the update.

Hope this helps! FYI you only have 10 days after install that update to rollback (per Microsoft website)

Verizon 1607 is current build of windows 10 I use
Version 1703 is the new updated one with the creator update
   
« Last Edit: July 15, 2017, 01:55:39 pm by Sara5dawn »

Sara5dawn

  • 89
  • +0/-1
    • View Profile
Re: Video will not play
« Reply #7 on: July 15, 2017, 02:02:14 pm »
Something to try...
I had a lot of problems with my windows 10 PC, just running kodi and installing addons. Turns out it was my crappy anti virus software, namely mcafee running a constant scan on programs and files on the PC. Just for curiosity, try disabling all your scans and firewall and see if there is a difference.
Otherwise, the above advice is excellent!

I too use mcafee and never had a problem with install addons for Kodi. I truly think it is the windows defender that causes the problem thats why I had to roll back to my previous version of windows 10 and turn defender off.

mdmm55

  • 13
  • +0/-0
    • View Profile
Re: Video will not play
« Reply #8 on: July 22, 2017, 01:25:07 pm »
Audio and Video Problems with KODI 17 Krypton in Android 6 Box
I am using only Legal videos and legal live tv channels now on Kodi 17.3 Kryopton
I am also facing 2 video problems
1-occasional it stops.
2- Video quality in these , videos and live tv is very poor. Kindly give me hints to fix this problem ,I am using
MBOX-M96X-AMLOGIC S905X-upgraded-A53. ANDROID 6.0 -Model M96X- 64Bit