KodiTips Forums

Video cuts off, no error

Phane

  • 2
  • +0/-0
    • View Profile
Video cuts off, no error
« on: July 18, 2017, 03:21:12 pm »
Hi folks,

Sorry if this has been answered already or has been posted elsewhere.

I use the Covenant addon with Kodi, but this seems to be an issue with other addons too.

When selecting a video to watch, it will find sources and play without issue. However, whenever it feels like it the video will just turn off and go back to the last screen before I started watching it. No error, nothing.

Reading online I noticed people said a possible fix was to use advancedsettings.xml to adjust settings including the cache, so I gave it a try. Same thing using multiple setting suggestions and then using Ares to automatically tweak it.

I use a 1GB RAM Android box with a S905X and Mali-450 on a wired connection with 200MB internet. Not the strongest piece of kit in the world but all it does is run Kodi so it does the job on a budget. That being said, with a wired connection on a strong download speed still not fixing the issue alongside advancedsettings.xml tweaks (issue is the same on wireless too), is it a possibility it could be the box? I have another one of the same model but it has the same issue so i'm not sure. At a bit of a loss basically.

Any ideas?

Thank you for your time.

TonyH

  • 329
  • +22/-3
    • View Profile
Re: Video cuts off, no error
« Reply #1 on: July 18, 2017, 04:37:05 pm »
What version of kodi are you running?

Buzz Marshall

  • 125
  • +11/-2
    • View Profile
Re: Video cuts off, no error
« Reply #2 on: July 18, 2017, 05:14:53 pm »
with the s905x SoC's its kinda hard to tell without a lot more info...

I've been developing closed systems for people now for about 5 years using my own Linux OS so I'm extremely well versed in the Amlogic SoC's...

Amlogics definately had video issues with the newer S90xx chips since they forced them on the manufacturers awhile back... They have had issues with firmware that vary and some brands of boxes are worse then others... some of it stems around poor video and networking firmware...

Some manufacturers boxes work better then others... A lot of the original S90x series came with Android 5 and seemed to be not to bad but with everyone wanting to go up to Android 6 things seemed to change some what and who the box maker was seemed to play a part(theres a lot of crappy clones around)... The way some of the manufactures make their products they are just copying someone else's and then Amlogic will partner up with them and give them a canned version of Android for their products while just catering the bootloader code to the actual hardware being used... Sometimes things seem to work but in other cases the product is plagued with issues... All of the better S905 or x based boxes usually have a healthy group of on-line guys working on bettering the software which is why its always best to buy a product that fits in with hardware people are working on...

Without knowing more though its really hard to say...

I would start by trying to play a local movie stored on the internal flash or a usb stick and see how that goes... if that plays ok from start to finish then i'd start looking into other things like the networking stuff... but start by trying to prove if its a video play back... it would good to also do the test using one of the movies you cant stream... find it and download it locally and use it and see what happens...

A S812 based box if you can still find them is way more solid and pretty much capable of delivering anything the S905 or S905x can do and being its older and discontinued they can be cheaper if you can find them...

Phane

  • 2
  • +0/-0
    • View Profile
Re: Video cuts off, no error
« Reply #3 on: July 18, 2017, 05:35:33 pm »
TonyH: Kodi 17.3.

Buzz Marshall: EgoIggo. I could link you the box if you like? Not sure if it's allowed to post such a thing on the forum so I could send it in a private message. The box is Android 6.0. I will try that suggestion and get back to this thread with the results.

I can very easily return the boxes if they're the issue.

On further thought, I just realised that I use a VPN with both boxes. Both are set on a location with low ping and speed tests indicate solid speeds very close to my maximum. Not sure if that would make a difference?

Thank you both :)

Buzz Marshall

  • 125
  • +11/-2
    • View Profile
Re: Video cuts off, no error
« Reply #4 on: July 18, 2017, 06:21:47 pm »
Hard to say about the VPN but usually ive always found that if i'm having issues using a vpn on some particular site that dont like it then the stream never seems to start at all... seeing as its starting and actually playing and then quiting i'd be inclined to think its not vpn related... easy enough tho to prove try using the stream without using the vpn and see what happens...

on another note it might be a good idea to look into kodi's log and find where the log mentions opening up the stream and looking forward from there in the log see if it mentions anything about dropping the stream... something like a time out or packet drop... those may help you narrow down whats going on...

EgoIggo, hm never heard of them them but from the specs and appearance it looks like someones OEM box they had branded for themselves... I'd need pictures of the motherboard and whatever screened on it to try and source which factory and model its based on...

based on a quick look online i see its all over amazon and based on what the various postings are using for spec i would take a quess and say because of the lack of 1 gig ethernet or the mention of bluetooth they are doing the same thing as Nexbox and a few others did which was use X in the name to mislead people into thinking the box had a S905X in it when in reality they have the older S905... Not that it means its bad but its somewhat misleading and would be older stock in a newer market and they seem kinda expensive... china was selling the A95X with 1g sram for less then 40 canadian... Now awhile back I did a system for someone that had a whole whack of the nexbox A95x 1g boxes units that came with Android 5 that worked ok but after he started upgrading his boxes to Android 6 he started having a lot of random issues with Kodi and some android issues i didnt really want to know about...lol... Anyways he's now running on my system with my compiles of Kodi which are currently 17.4 rc's and he's not had any issues even using wifi...

The only reason i mention this is because his problems started on the shift up to Android 6...

Its so hard now a days tho to say as theres so many clones in the market that without actually looking at board level you really have no idea of what your getting... which is why i no longer do boxes other then what i recommend and have them bring in from one specific plant...