KodiTips Forums

Covenant not displaying videos unless I go to main menu

andarats

  • 4
  • +0/-0
    • View Profile
Covenant not displaying videos unless I go to main menu
« on: August 07, 2017, 10:56:00 am »
Hi all!
I couple of days ago I installed the new Kodi 17.3 and Covenant. It seemed to work well, finding movies/tv shows and links. However, when I click on one link, it seems to start playing but it comes back to the search window and displays a message at the top right of the screen with the info of the movie/show "playing". If I check my remote app, I can see the movie is running in a sort of background as I see the time passing.  The only way to watch the movie is to return back to the Kodi main menu and then it sometimes displays the movie.
To install covenant I've followed the guide from koditips (http://koditips.com/covenant-kodi-install-new-exodus-addon/)
I am using a Raspberry PI 3 with Raspbian.

I think this is a very weird issue or maybe I am simply missing an option/button in Kodi?  :-\

Can somebody help me please?

Thanks!



TonyH

  • 584
  • +39/-3
  • You have a 50-50 chance if you follow my advice 😂
    • View Profile
Re: Covenant not displaying videos unless I go to main menu
« Reply #1 on: August 07, 2017, 06:47:38 pm »
I remember this issue, something to do with the video settings in kodi. I'll have a look when I get home.

TonyH

  • 584
  • +39/-3
  • You have a 50-50 chance if you follow my advice 😂
    • View Profile
Re: Covenant not displaying videos unless I go to main menu
« Reply #2 on: August 08, 2017, 01:50:48 am »
settings/player/video/sinc playback to display, check that one on
settings/player/video/enable HQ scalers for scaling, turn this value to zero
Try those two things first

Iggs

  • 19
  • +0/-0
    • View Profile
Re: Covenant not displaying videos unless I go to main menu
« Reply #3 on: August 08, 2017, 07:25:41 am »
You may also find by moving to the far left side of the screen, in the menu that opens up and at the bottom is a button that will bring the video back to full screen.  This won't fix anything, but may let you watch your movie.

andarats

  • 4
  • +0/-0
    • View Profile
Re: Covenant not displaying videos unless I go to main menu
« Reply #4 on: August 08, 2017, 02:39:27 pm »
settings/player/video/sinc playback to display, check that one on
settings/player/video/enable HQ scalers for scaling, turn this value to zero
Try those two things first

Hi!
I've modified the sync playback to display but I couldn't find the HQ scalers option. Even in expert mode.
It didn't work  :-[

What I realised is that the menu options are out of the screen, maybe something related with the screensize is provoking this?



andarats

  • 4
  • +0/-0
    • View Profile
Re: Covenant not displaying videos unless I go to main menu
« Reply #5 on: August 08, 2017, 02:43:42 pm »
You may also find by moving to the far left side of the screen, in the menu that opens up and at the bottom is a button that will bring the video back to full screen.  This won't fix anything, but may let you watch your movie.

Hi!
I've tried that and it is working for some videos but not for others.
I realised some of the menus are not fitting the screenshot. Maybe this is related?

Thanks both!

TonyH

  • 584
  • +39/-3
  • You have a 50-50 chance if you follow my advice 😂
    • View Profile
Re: Covenant not displaying videos unless I go to main menu
« Reply #6 on: August 08, 2017, 03:38:00 pm »
If you can't see the full screen, look in the display settings

The HQ scalers setting is just below the sinc playback setting, just scroll down in the options
« Last Edit: August 08, 2017, 03:39:38 pm by TonyH »

andarats

  • 4
  • +0/-0
    • View Profile
Re: Covenant not displaying videos unless I go to main menu
« Reply #7 on: August 22, 2017, 11:12:30 am »
Thanks all for the ideas!
I am still struggling with it but the idea to click on the full screen works in 60% of the cases  :-\
Will keep digging!

Buzz Marshall

  • 271
  • +29/-2
  • Puff, Puff, Pass
    • View Profile
Re: Covenant not displaying videos unless I go to main menu
« Reply #8 on: August 22, 2017, 07:03:04 pm »
sounds like the media player overlay isnt loading properly...

is the problem just confined to Covenant or are other plugins giving you the same problem...

Also make sure you adjust kodi's screen size with in the video system panel... probably not the problem but still you should check that cause if its way way off it can mess with the overlay setup...