KodiTips Forums

Covenant not loading anything.

jplummer93

  • 3
  • +0/-0
    • View Profile
Covenant not loading anything.
« on: August 08, 2017, 04:02:34 pm »
Hi everyone,

So my Grandad bought a fire stick the other day and I went to set up Kodi and Covenant on it.

They both went on absolutely fine. However when I go into Covenant and click on Movies or Tv Shows, and 'People Watching' for example, the little wheel spins for a few seconds.. and then nothing. No matter what I click nothing loads? Does anyone know why this could be happening? I went home and downloaded both on my laptop the same way and it all worked fine.

Thanks,

Jamie

Parisi01

  • 1
  • +0/-0
    • View Profile
Re: Covenant not loading anything.
« Reply #1 on: August 09, 2017, 02:36:57 pm »
Hi everyone,

I am having the same problem here with covenant on firestick. When trying to load any category, people watching for example, it tries to load for a couple of seconds but then stops, there are no error messages or anything.

I have defaulted fire stick and tried various versions of kodi and problem still exsits. Currently on latest version and just installed from colossus repository but still the same issue. I have a rapberry pi running covenant and it works perfect. Any ideas anyone?

jplummer93

  • 3
  • +0/-0
    • View Profile
Re: Covenant not loading anything.
« Reply #2 on: August 10, 2017, 04:59:21 am »
Hi everyone,

I am having the same problem here with covenant on firestick. When trying to load any category, people watching for example, it tries to load for a couple of seconds but then stops, there are no error messages or anything.

I have defaulted fire stick and tried various versions of kodi and problem still exsits. Currently on latest version and just installed from colossus repository but still the same issue. I have a rapberry pi running covenant and it works perfect. Any ideas anyone?

This is so annoying I literally have no idea why this is not working. I'm going round there tonight to try and have another play. He has BT Hub and I'm going to try and turn off the 'Smart Setup' but I don't think that will work either. No one else on the internet seems to be having this problem. I can only think it's maybe a firewall/internet issue as I've done nothing wrong on the download.

Deggsy56

  • 21
  • +2/-0
    • View Profile
Re: Covenant not loading anything.
« Reply #3 on: August 10, 2017, 12:21:14 pm »
I  read somewhere that Kodi doesn't like firesticks. Better off with an up-to-date android box.

flhthemi

  • 103
  • +5/-0
  • FLHT = Harley Davidson HEMI = Dodge Challenger SRT
    • View Profile
Re: Covenant not loading anything.
« Reply #4 on: August 10, 2017, 01:33:23 pm »
BEST off with a Windows 10 based device ;)

hatrix

  • 189
  • +16/-0
  • I'm the captain now.
    • View Profile
Re: Covenant not loading anything.
« Reply #5 on: August 10, 2017, 01:39:16 pm »
the device isnt the issue, i have plenty of family running it fine on firesticks.
it may have something to do with the api key.

jplummer93

  • 3
  • +0/-0
    • View Profile
Re: Covenant not loading anything.
« Reply #6 on: August 14, 2017, 05:26:18 am »
Hi everyone,

I am having the same problem here with covenant on firestick. When trying to load any category, people watching for example, it tries to load for a couple of seconds but then stops, there are no error messages or anything.

I have defaulted fire stick and tried various versions of kodi and problem still exsits. Currently on latest version and just installed from colossus repository but still the same issue. I have a rapberry pi running covenant and it works perfect. Any ideas anyone?

This is so annoying I literally have no idea why this is not working. I'm going round there tonight to try and have another play. He has BT Hub and I'm going to try and turn off the 'Smart Setup' but I don't think that will work either. No one else on the internet seems to be having this problem. I can only think it's maybe a firewall/internet issue as I've done nothing wrong on the download.

SOLVED

I turned the smart set up off on the BT Hub and it all works fine.