KodiTips Forums

Convenant help needed

balrog

  • 1
  • +0/-0
    • View Profile
Convenant help needed
« on: October 23, 2017, 03:36:13 am »
Hi Folks,

Can anyone help with aiding me to getting Convenant, Elisium, BENNU, BOB unleashed and UK turks addons to update.  I did a Jarvis 16.4 update on my firestick and I cant seem to be able to watch the content as I did before.  I get SALTS failure to update initially then a check the log after for the other apps as I try to access them.
I'm new to this and would appreciate help

Thanks :)

flhthemi

  • 223
  • +11/-1
  • FLHT = Harley Davidson HEMI = Dodge Challenger SRT
    • View Profile
Re: Convenant help needed
« Reply #1 on: October 23, 2017, 09:13:54 am »
You need to, probably, get rid of the Jarvis  version and install Kodi 17.4 Krypton. Addons you are trying to use may no longer be compatible with Jarvis version. However, to do this your Android version must be at least 5.xx or better or Krypton won't install or show up in the play store and maybe not the Amazon store either. I don't know as I don't use a firething :)
« Last Edit: October 23, 2017, 09:16:28 am by flhthemi »

gwilly7

  • 40
  • +3/-1
    • View Profile
Re: Convenant help needed
« Reply #2 on: October 23, 2017, 02:37:02 pm »
There was not a 16.4 for Jarvis.  If you  have upgraded to Krypton you have to go to addons and setting and allow unknown sources for 3rd party addons to update or install.